NetDocuments UK - Service Distruption

Major incident Business Applications
2026-05-21 15:58 BST · 20 minutes

Updates

Resolved

Latest update from NetDocs:

Monitoring - We have remediated the issue with the UK Service. The Service response has returned to normal.

We will continue to monitor the platform and will update this post should anything change.

May 21, 2026 · 16:18 BST
Investigating

Investigating - NetDocs are currently investigating an issue affecting the UK Service.

We will provide updates to this post as more information becomes available.

All updates gathered via https://trust-eu.netdocuments.com/

May 21, 2026 · 15:58 BST

← Back